Under gårdagskvällen fortsatte mitt arbete med att återställa sidan till vad den var innan jag pajade den.

Under lugna stunder på jobbet passade jag också på att indexera lite bilder till mediabiblioteket. 3000+ var nog närmar 4000 bilder, för när jag loggade in igår på jobbet så hade jag 3768 bilder kvar att indexera. Nu har jag typ kommit halvvägs och har färre än 2000 bilder kvar. Eftersom jag indexerar 100 bilder åt gången så blir det 20 körningar till. Tillägget jag använder är inte jättesnabbt men det fungerar och jag har inte bråttom.

När jag är klar med återställningen tänker jag skriva en sammanfattande steg-för-steg-guide hur jag gick till väga. Något jag hade uppskattat att hitta när jag körde fast.

I går kväll….

  • installerade jag Google Site Kit och uppdaterat adresser i analytics och webmaster tool
  • fortsatte jag att registrera bilder
  • Moddade jag temat så att utvalda bilder inte visas i inlägg och arkiv
  • fixade jag en Facebook-widget
  • fixade jag mina fotosidor (google-photo)
  • skrev jag ett inlägg om skedand

Alla googlegrejer var ju inga större problem, lite rörigt att hitta på deras paneler när man bara vill uppdatera en adress, men det gick bra.

Att visa en widget med sin facebook-sida borde vara en enkel sak, men jag tycker att det är en smula drygt att behöva använda en egen app på Facebook för detta. Kanske finns enklare sätt som jag missat.

När det kommer till visningen av utvalda bilder i temat så tycker jag att det är riktigt störande att varenda tema promt ska visa den utvalda bilden överst i varje inlägg. Jag gillar utvalda bilder. Då styr jag över vilken bild som ska visas när man länkar till inlägget eller sidan. På vissa teman där man bara ser ett utdrag ur texten på första sidan är det också snyggt med en bild till och då vill jag kunna bestämma vilken bild.

Men i själva inlägget eller på sidan så vill jag bestämma VAR bilden visas. Bara för att den är utvald behöver det inte betyda att jag vill visa den överst.

Men ändå så har 90% av alla teman den funktionen. Riktigt irriterande.

Lösningen för mig har varit att gå in i temaredigeraren och ta bort koden som visar bilden. Jag har samma tema nu som innan katastrofen, men när jag tar bort koden så är bilden ändå kvar. Jag testar fram och tillbaka utan att lyckas.

Detta började jag med redan i förrgår och jag var riktigt frustrerad över att inte få till det. När jag började labba lite på min testsida med alternativa teman, så upptäckte jag att det var ett tillägg för cash-lagring av sidan som ställde till det. När jag gick in och tömde cashen så löste sig allt.

Kvar att göra

  • fortsätta med bildindexeringen
  • Fixa några widgets som syns i mobilversionen
  • Börja blogga som vanligt igen